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Copyright
The documentation and the software included with this product are copyrighted 2025
by Advantech Co., Ltd. All rights are reserved. Advantech Co., Ltd. reserves the right
to make improvements in the products described in this manual at any time without
notice. No part of this manual may be reproduced, copied, translated, or transmitted
in any form or by any means without the prior written permission of Advantech Co.,
Ltd. The information provided in this manual is intended to be accurate and reliable.
However, Advantech Co., Ltd. assumes no responsibility for its use, nor for any
infringements of the rights of third parties that may result from its use.

Acknowledgments
Intel and Pentium are trademarks of Intel Corporation.
Microsoft Windows and MS-DOS are registered trademarks of Microsoft Corp.
All other product names or trademarks are properties of their respective owners.

Product Warranty (5 years)
Advantech warrants the original purchaser that each of its products will be free from
defects in materials and workmanship for five years from the date of purchase. 
This warranty does not apply to any products that have been repaired or altered by
persons other than repair personnel authorized by Advantech, or products that have
been subject to misuse, abuse, accident, or improper installation. Advantech
assumes no liability under the terms of this warranty as a consequence of such
events.
Because of Advantech’s high quality-control standards and rigorous testing, most
customers never need to use our repair service. If an Advantech product is defective,
it will be repaired or replaced free of charge during the warranty period. For out-of-
warranty repairs, customers will be billed according to the cost of replacement mate-
rials, service time, and freight. Please consult your dealer for more details.
If you believe your product is defective, follow the steps outlined below.
1. Collect all the information about the problem encountered. (For example, CPU 

speed, Advantech products used, other hardware and software used, etc.) Note 
anything abnormal and list any onscreen messages displayed when the prob-
lem occurs.

2. Call your dealer and describe the problem. Please have your manual, product, 
and any helpful information readily available.

3. If your product is diagnosed as defective, obtain a return merchandise authori-
zation (RMA) number from your dealer. This allows us to process your return 
more quickly.

4. Carefully pack the defective product, a completed Repair and Replacement 
Order Card, and a proof of purchase date (such as a photocopy of your sales 
receipt) into a shippable container. Products returned without a proof of pur-
chase date are not eligible for warranty service.

5. Write the RMA number clearly on the outside of the package and ship the pack-
age prepaid to your dealer.

Part No. 2003152600 Edition 1
Printed in China October 2025
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 Declaration of Conformity
CE

This product has passed the CE test for environmental specifications when shielded
cables are used for external wiring. We recommend the use of shielded cables. This
type of cable is available from Advantech. Please contact your local supplier for
ordering information.
Test conditions for passing also include the equipment being operated within an
industrial enclosure. In order to protect the product from damage caused by electro-
static discharge (ESD) and EMI leakage, we strongly recommend the use of CE-
compliant industrial enclosure products.

FCC Class A

This equipment has been tested and found to comply with the limits for a Class A dig-
ital device, pursuant to part 15 of the FCC Rules. These limits are designed to pro-
vide reasonable protection against harmful interference when the equipment is
operated in a commercial environment. This equipment generates, uses, and can
radiate radio frequency energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio communications. Opera-
tion of this equipment in a residential area is likely to cause harmful interference. In
this event, users are required to correct the interference at their own expense.

Technical Support and Assistance
1. Visit the Advantech website at www.advantech.com/support to obtain the latest 

product information.
2. Contact your distributor, sales representative, or Advantech's customer service 

center for technical support if you need additional assistance. Please have the 
following information ready before calling:
– Product name and serial number
– Description of your peripheral attachments
– Description of your software (operating system, version, application software, 

etc.)
– A complete description of the problem
– The exact wording of any error messages
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Warnings, Cautions, and Notes

Document Feedback
To assist us with improving this manual, we welcome all comments and constructive
criticism. Please send all such feedback in writing to support@advantech.com.

Packing List
Before system installation, check that the items listed below are included and in good
condition. If any item does not accord with the list, contact your dealer immediately.
 1 x Device Server
 1 x Rack mount kits, including two L-shape metal plates and twelve screws

Optional Accessories

Warning! Warnings indicate conditions that if not observed can cause personal 
injury!

Caution! Cautions are included to help prevent hardware damage and data 
losses. E.g.
“Batteries are at risk of exploding if incorrectly installed. Do not attempt 
to recharge, force open, or heat the battery. Replace the battery only 
with the same or equivalent type as recommended by the manufacturer. 
Discard used batteries according to the manufacturer's instructions.”

Note! Notes provide additional optional information.

Part Number Description
OPT1J-AE 30cm RJ45 to DB9 (male) cable
1702002600 Power Cable US Plug 1.8m
1702002605 Power Cable EU Plug 1.8m
1702031801-11 Power Cable UK Plug 1.8m
1700000596-11 Power Cable China Plug 1.8m
1702031836 Power Cable Australia Plug 1.8m
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 Safety Instructions
1. Read these safety instructions carefully.
2. Retain this user manual for future reference.
3. Disconnect the equipment from all power outlets before cleaning. Use only a 

damp cloth for cleaning. Do not use liquid or spray detergents.
4. For pluggable equipment, the power outlet socket must be located near the 

equipment and easily accessible.
5. Protect the equipment from humidity.
6. Place the equipment on a reliable surface during installation. Dropping or letting 

the equipment fall may cause damage.
7. The openings on the enclosure are for air convection. Protect the equipment 

from overheating. Do not cover the openings.
8. Ensure that the voltage of the power source is correct before connecting the 

equipment to a power outlet.
9. Position the power cord away from high-traffic areas. Do not place anything over 

the power cord.
10. All cautions and warnings on the equipment should be noted.
11. If the equipment is not used for a long time, disconnect it from the power source 

to avoid damage from transient overvoltage.
12. Never pour liquid into an opening. This may cause fire or electrical shock.
13. Never open the equipment. For safety reasons, the equipment should be 

opened only by qualified service personnel.
14. If any of the following occurs, have the equipment checked by service person-

nel:
– The power cord or plug is damaged.
– Liquid has penetrated the equipment.
– The equipment has been exposed to moisture.
– The equipment is malfunctioning, or does not operate according to the user 

manual.
– The equipment has been dropped and damaged.
– The equipment show obvious signs of breakage.

15. Do not leave the equipment in an environment with a storage temperature of 
below -40°C (-40°F) or above 85°C (185°F) as this may damage the compo-
nents. The equipment should be kept in a controlled environment.

16. In accordance with IEC 704-1:1982 specifications, the sound pressure level at 
the operator's position does not exceed 70 dB (A).

DISCLAIMER: These instructions are provided according to IEC 704-1 standards.
Advantech disclaims all responsibility for the accuracy of any statements contained
herein.
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Safety Precautions - Static Electricity
Follow these simple precautions to protect yourself from harm and the products from
damage.
 To avoid electrical shock, always disconnect the power from the PC chassis 

before manual handling. Do not touch any components on the CPU card or 
other cards while the PC is powered on.

 Disconnect the power before making any configuration changes. A sudden rush 
of power after connecting a jumper or installing a card may damage sensitive 
electronic components.

Safety Precaution-Power Cord Safety
Please read the following safety information carefully before installing the Serial
Device Server:

 The unit must be connected to an earthed (grounded) outlet to comply with 
international safety standards.

 The unit must be powered by using listed power source, rated 12-48Vdc, 0.7A 
minimum and Tma 75'C comply with LPS or PS2.

 Do not connect the unit to an A.C, outlet (power supply) without an earth 
(ground) connection.

 The socket outlet must be near to the unit and easily accessible, You can only 
remove power from the unit by disconnecting the power cord from the outlet.

Safety Precaution -Shock Hazard
Electrical current from power, telephone, and communication cables is hazardous.To
avoid a shock hazard:
 Do not connect or disconnect any cables or perform installation, maintenance, 

or reconfiguration of this product during an electrical storm.
 Connect all power cords to a properly wired and grounded power source.
 Connect to properly wired power sources any equipment that will be attached to 

this product.
 When possible, use one hand only to connect or disconnect signal cables.Never 

turn on any equipment when there is evidence of fire, water, or structural dam-
age.

 Disconnect the attached Ac power cords, Dc power sources, network connec-
tions, telecommunications systems, and serial cables before you open the 
device covers, unless you are instructed otherwise in the installation and config-
uration procedures.

 Connect and disconnect cables as described in the following table when you 
install, move, or open covers on this product or attached devices.

Warning! Installation and removal of the unit must be carried out by qualified per-
sonnel only.
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1.1 Overview
The EKI-1526 Series are network-based serial device servers that connect RS-232/
422/485 serial devices, such as PLC, meters, sensors, and barcode readers, directly
to a TCP/IP network.
Once connected through a EKI-1526 Series serial server, devices are able to send
and receive data through a network. This extends the traditional COM ports of a PC,
with access over a TCP/IP network. Through networking, you can control and moni-
tor remote serial devices over either a LAN or WAN. Since the EKI-1526 Series is
connected through a TCP/IP network, you may need to know some basic facts about
networking in order to connect the server correctly.
The EKI-152x Series features two independent Ethernet ports and MAC addresses
to provide a redundant network mechanism to avoid data loss. The EKI-1526 Series
provides various operations: COM port redirection mode (Virtual COM Port mode),
TCP Server/ Client mode, UDP mode, Control mode and RFC2217 mode. Detailed
descriptions of each operation are provided in a later chapter.

1.2 Device Features
 16-port RS-232/422/485 serial communication
 Provides 2 x 10/100 Mbps Ethernet ports for LAN redundancy
 Secure VCOM (Virtual COM), USDG (TCP and UDP) operation modes
 Configuration encryption and image encryption ensures trusted operations.
 Device-level redundancy with Virtual Gateway
 Supports up to 921.6 kbps, and any baud rate setting
 Support SSDP for effortless device discovery
 Provides rich configuration methods: Web Browser, Windows utility, Telnet con-

sole and Serial console
 SNMP MIB-II for network management
 Built-in buzzer for easy location
 Standard 1U rack-mount size
 Rear wiring
 Automatic RS-485 direction flow control
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1.3 Specifications

Table 1.1: Specifications
Specifications Description

Interface
I/O Port

 2 x RJ-45
 16 x RS-232/422/485
See Ethernet and Serial Communications in this
table for further information.

Power 
Connector Power socket

Physical

Enclosure SECC chassis
Installation Rack
Dimensions 
(W x H x D) 438 x 43.6 x 153.9 mm

LED Display
System LED Power, Status

Port LED  LAN: Speed, Link/Active
 Serial: Tx, Rx

Environment

Operating 
Temperature -40 ~ 70°C (-40 ~ 158°F)

Storage 
Temperature -20 ~ 80°C (-4 ~ 176°F)

Ambient Relative 
Humidity 95% RH 

Ethernet 
Communications

Compatibility IEEE 802.3, IEEE 802.3u, IEEE 802.3ab
Speed 10/100/1000 Mbps, auto MDI/MDIX
Port Connector 8-pin RJ-45
Protection Built-in 1.5 KV magnetic isolation

Serial 
Communications

Port Type RS-232/422/485-2w/485-4w, software selectable 
Port Connector 8-pin RJ-45
Data Bits 5, 6, 7, 8
Stop Bits 1, 1.5, 2
Parity None, Odd, Even, Space, Mark
Flow Control XON/XOFF, RTS/CTS

Baud Rate  50 bps ~ 921.6 kbps, any baud rate setting
 16 ports up to 230.4 kbps simultaneously

Security
Authentication RADIUS, LDAP, Local Management 
Security Protocols SNMPv3, HTTPS (TLS 1.3), SSH

Power
Power Consumption 6.4W
Power Input 100 ~ 240 VAC, 50 ~ 60 Hz
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Software

OS Support for Utility 32-bit/64-bit Windows XP/7/8/8.1/10/11, Win-
dows Server 2016/2019/2022

Utility Advantech EKI Device Configuration Utility

Operation Modes

 Secure
– COM port redirection mode (Virtual 

COM)(VCOM 2.0)
– TCP server (polling) mode (USDG 2.0)
– TCP client (event handling) mode 

(USDG 2.0)
– Pair connection (peer to peer) mode 

(USDG 2.0)
– SSH Console Mode

 Standard
– COM port redirection mode (Virtual 

COM)(VCOM 2.0)
– TCP/UDP server (polling) mode (USDG 

1.0)
– TCP/UDP client (event handling) mode 

(USDG 1.0)
– Pair connection (peer to peer) mode 

(USDG 1.0)
– RFC2217 Mode

Configuration Web Browser(HTTP/HTTPS), Windows utility, 
Telnet console, Serial console

Management SNMP MIB-II
Regulatory 
Approvals EMC CE, FCC Part 15 Subpart B (Class A)

Table 1.1: Specifications



Chapter 2
2 Getting Started



EKI-1526 User Manual 6

2.1 Hardware Overview
2.1.1 Front View

The following view shows the EKI-1526N.

Figure 2.1 Front View

2.1.2 Rear View
The following view shows the EKI-1526N.

Figure 2.2 Rear View

2.1.3 LED Indicators
The following view shows the EKI-1526N.

Figure 2.3 System LED Panel

Table 2.1: Front View
No. Item Description
1 Reset button Button allows for system soft reset (3 sec.).
2 Serial port DB9 pinout, console port (female).
3 System LED panel See “LED Indicators” on page 8 for further details.

Table 2.2: Table 2.3: Rear View
No. Item Description
1 Power button Turn the device on and off.
2 AC power in Supports 100 ~ 240 VAC, 50 ~ 60 Hz.
3 ETH port 2 x RJ-45 ports
4 Serial communication 16 x RJ-45 ports
5 Ground terminal Screw terminal used to ground chassis.
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2.1.4 Dimensions
The following view shows the EKI-1526N.
 

Figure 2.4 EKI-1526N Dimensions

Table 2.4: LED Indicators
No. LED Name LED Color Status Description

1 PWR GREEN
ON Power is on

OFF Power is off or power error condition 
exists

2 Link/Active GREEN
ON Valid network link
OFF Invalid network link

3 RX GREEN
ON Data being received
OFF No data transmitted

4 Status GREEN
ON The device server has been located by 

utility’s location function
BLINKING System is ready (1cycle/sec.)
OFF System is powered off

5 Speed
GREEN ON 1000 Mbps speed

AMBER
ON 100 Mbps speed
OFF 10 Mbps speed

6 TX AMBER
ON Data being transmitted
OF No data transmitted

1.
25

31
.8
0
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43
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0
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18.31
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2.2 Connecting Hardware

2.2.1 Rack Mount
1. Align the rack mount brackets with the holes on the Serial Device Server.
2. Secure the rack mount brackets with screws.
 

Figure 2.5 Installing the Rack Mount Brackets

Caution! Devices in use may become hot to the touch. To prevent damage or 
injury, allow the device time to cool down before attempting to service it.
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3. Align the Serial Device Server with the posts on the rack cabinet.
4. Secure the Serial Device Server with screws.
 

Figure 2.6 Installing the Serial Device Server
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2.2.2 Serial Connection
the EKI-1526N provides 16 RJ-45 connectors. The RS-232/422/485 pin assignments
are shown below.

Figure 2.7 RJ45 Plug & RJ45 Connector Pin Assignment
 

Figure 2.8 RJ45 to DB9 Cable Assignment

The optional accessory OPT1J-AE for EKI-1526N is an RJ-45 to DB9 (male) cable.
Connect the serial data cable between the EKI-1526N and the serial devices.

Figure 2.9 RJ45 to DB9 (Male) Cable

Table 2.5: EKI-1526N Serial Port Pin Assignments
Pin 1 2 3 4 5 6 7 8 9
RS-232 DCD RX TX DTR GND DSR RTS CTS -
RS-422 TX- TX+ RX+ RX- GND
RS-485 DATA- DATA+ GND
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2.2.3 Power Connection

Warning! Power down and disconnect the power cord before servicing or wiring 
the serial device server.

Warning! Do not disconnect modules or cabling unless the power is first switched 
off.
The device only supports the voltage outlined in the type plate. Do not 
use any other power components except those specifically designated 
for the serial device server.

Warning! Disconnect the power cord before installation or cable wiring.

Warning! Risk of explosion if the battery is removed and/or replaced by an incor-
rect type.

Warning! Risk of defeating the safeguard if the battery is removed or replaced by 
an incorrect type.

Warning! Risk of explosion if the battery is disposed in fire or hot environment or 
mechanically damaged--denting, crushing, and piercing the cell case.

Warning! Risk of explosion or leakage of flammable liquid or gas if the battery is 
left in an extremely high temperature environment.

Warning! Dispose of used batteries in accordance with your local environmental 
regulations
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The following is only available for EKI-1526N AC power line with its AC connector. If
the power is properly supplied, you can turn on the power switch and the PWR LED
will light green.

Figure 2.10 Connecting AC Power

Caution! Electrical current from power, telephone, and communication cables is 
hazardous.
To avoid a shock hazard:
 Do not connect or disconnect any cables or perform installation, 

maintenance, or reconfiguration of this product during an electrical 
storm.

 Connect all power cords to a properly wired and grounded power 
source.

 Connect to properly wired power sources any equipment that will 
be attached to this product.

 When possible, use one hand only to connect or disconnect signal 
cables.

 Never turn on any equipment when there is evidence of fire, water, 
or structural damage.

 Disconnect the attached AC power cords, DC power sources, net-
work connections, telecommunications systems, and serial cables 
before you open the device covers, unless you are instructed oth-
erwise in the installation and configuration procedures.

 Connect and disconnect cables as described in the following table 
when you install, move, or open covers on this product or attached 
devices.



Chapter 3
3 Utility Configuration
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3.1 Configuration Utility Overview
Advantech EKI series serial device servers provide an easy-to-use utility to configure
your serial device server through an Ethernet connection. For secure administration,
it can also restrict the access rights for configuration to only one host PC. With this
secure function enabled, other PCs will not have permission for configuration. After
the installation program on the Advantech EKI Device Configuration Utility is finished,
the serial device servers are ready for use and configuration.
Advantech EKI Device Configuration Utility is an excellent device server manage-
ment tool. You can connect and configure the local and remote Advantech serial
device servers easily. The utility provides access to the following functions:
 Configure the network settings (you can set the IP address, Gateway address, 

and Subnet mask).
 View and set the serial port parameters (configure operating mode, baud rate, 

serial port settings and operating mode settings).
 Perform diagnostic tests (virtual COM port testing, port status list).
 Perform administrative functions (export and import the serial device server set-

ting, manage access IP, a descriptive name, upgrade firmware).

3.2 Installing the Configuration Utility
The Advantech EKI Device Configuration Utility is available for download. Please
download the latest version from Advantech’s website at http://www.advantech.com.

3.2.1 Installing the Software 
1. Please download the Advantech EKI Device Configuration Utility from the 

Advantech website at http://www.advantech.com. and then run the following 
setup program to begin the installation process: EKI_Device_Configuration_Util-
ity_[version].exe

2. If there is an existing COM port mapping utility on the host PC, remove it at this 
time. A system reboot may be necessary before continuing the installation.

3. Once the InstallShield Wizard screen displays, click Next to proceed with the 
installation.

Note! The EKI-1526 can be configured via the Web Interface or the EKI Utility 
running on a PC. The Web Interface is the primary setup tool, offering 
both basic and advanced configuration features. For Web Interface con-
figuration, please refer to Chapter 6.

Note! This application requires Microsoft .NET Framework version 4.0 or later.
Windows 10 (post-2019) and Windows 11 already include .NET 4.8 by 
default, so no additional installation is normally required.
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Figure 3.1 InstallShield Wizard 1 of 4

4. The Software License Agreement displays, press I Agree to continue or Cancel 
to stop the installation.

 

Figure 3.2 InstallShield Wizard 2 of 4

The InstallShield continues and a status screen display. The default installation path
is C:\Program Files\EKI Device Configuration Utility.
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Figure 3.3 InstallShield Wizard 3 of 4

5. Once the installation of the package is finished a Configuration Utility Setup 
screen display. Click Finish to conclude the process and exit the InstallShield 
Wizard.

 

Figure 3.4 InstallShield Wizard 4 of 4 
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3.3 Menu Bar
You can open the Configuration Utility from the Windows Start Menu by clicking Start
> All Programs > EKI Device Configuration Utility > EKI Device Configuration Utility.
The Configuration Utility displays as shown in the following figure.
 

Figure 3.5 Configuration Utility Overview

Table 3.1: Configuration Utility Overview
No Item Description
1 Menu Bar Displays File, View, Management, Tools and Help.
2 Quick Tool Bar Useful management functions shortcuts.

3 Serial Device Server 
List Area

Available devices are listed in this area. Devices and COM 
ports can be organized or grouped in this area. 

4 Information Panel Click on the devices or move cursor to the devices, the 
related information is shown in this area.

5 Status Bar Displays the current time.

6 Configuration Area Click on the item on the Device Server List Area, the con-
figuration page displays. 
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3.4 Quick Tool Bar
The Advantech EKI Device Configuration Utility makes use of a Quick Tool Bar menu
to allow quick access to the management functions. See the following figure for fur-
ther information.
 

Figure 3.6 Quick Tool Bar Overview

Table 3.2: Quick Tool Bar Overview
Icon Item Description

 
Utility Settings Clear 

Configure the general settings for the Main Form Setting 
and Device Manager menus.
 Refer to “Utility Settings” on page 40.

 
Configuration Wizard 

Start the software wizard (setup assistant) to lead you 
through the VCOM configuration process for device 
server product.

 

Clear Device List and 
Search Again

Click to clear listed device servers in the Serial Device 
Server List Area and initiate a new search.
NOTE: A continuous click of the icon results in the follow-
ing message: Please do not refresh so frequently.

 
Search Again

Click to search for serial device servers on the local LAN.

 

Add IP Address to 
Favorite

Click to include the selected IP Address into the Favor-
ites list group.

 

Search for a Range of 
IP Addresses

Click to begin a range search. Enter the beginning and 
ending IP addressed to being a search within the string 
parameters. 

 

Manual Direct Map-
ping Virtual COM Port

Click to add a target by selecting the Device Type and 
inputting the IP address without physically connecting 
the serial device server to the network.
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3.5 Utility Settings
3.5.1 Utility Settings

3.5.1.1 Main Form Setting
Click View > Settings to configure utility settings.
 

Figure 3.7 View > Settings > Main Form Setting

Table 3.3: Main Form Setting
Item Description
Main Window Settings
Maximum Main Window On 
Load

Check the box to enable the limiting of main windows on-
load to the maximum value.

Log Settings

Show Log Message Window Check the check box to activate the AdvLogMessage form. 
The Form Log message displays. 

Save Log to File Check the check box to save log to file.

Browse If the Save Log to File option is enabled, click Browse to 
select a file to save log data. 

Language Settings

Interface Language
Click the drop-down menu to select an interface language: 
Traditional Chinese, Simplified Chinese or English.
NOTE: A restart is required for the settings to take effect.

OK Click OK to save and exit the Utility Settings menu.
Cancel Click Cancel to discard the changes.
Apply Click Apply to save the main form settings.
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3.5.1.2 Device Manager
 

Figure 3.8 View > Settings > Device Manager

Table 3.4: Device Manager
Item Description
Device Manager

Tree View Grouping Click the drop-down menu to enable or disable 
grouping.

Show Empty Device Type Node Check the check box to show empty device type 
node or not.

Expand New Appended Device Node Check the check box to expand a new appended 
device node.

Device Auto Detection

Auto detect devices every X second Enter a value to specify the time to auto detect 
devices.

Check device alive every X second Enter a value to specify the time to check device 
alive

Mark device as lost contact after retry 
for X times

Enter a value to specify the time to mark device as 
lost contact.

Unsigned Hardware Installation
Automatic answer for unsigned hard-
ware installation

Check the check box to enable or disable answer 
automatically for unsigned hardware installation

OK Click OK to save and exit the utility setting.
Cancel Click Cancel to discard the changes.
Apply Click Apply to save the utility setting.
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3.5.2 Discovering Your Device Server

Figure 3.9 Network 

3.5.2.1 Auto Searching
Advantech Serial Device Server Configuration Utility will automatically search all the
EKI-1526 Series device servers on the network and show them on the Serial Device
Server List Area of the utility. The utility provides an auto-search function to show
your device (s) by simply executing the configuration utility program from the Start
Menu.
From here all device on the same network domain will be searched and displayed on
Device Server List Area. You can click on the device name to show the features of
the specific device. 
Click on the “+” before the model name, and the utility will expand the tree structure
to show the individual device name. Click on the “-” minus symbol before the model
name, and the utility will collapse the tree structure.

Figure 3.10 Open View of Serial Device Configuration Utility

Note! The EKI-152x supports SSDP (Simple Service Discovery Protocol). 
After enabling the SSDP function on the EKI-152x configuration web-
page, users can use Windows Network Discovery to easily discover the 
EKI-152x.
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In the previous figure, the EKI-1526 Series device server is listed as EKI-1526-D-
26DDC7.

Select the device in this sub-tree. The first tab on the Configuration Area shows the
summary of “Basic Information” included device type, version, and name, “Ethernet
Information”, and “Serial Port Information”. The serial port information frame displays
the operation mode, status and connected host IP.
Click on the “+” before the device name, and the utility will expand the interfaces on
this device server.
 

Figure 3.11 Selecting a Device

Click on each item to enter the configuration page to change the setting. The configu-
ration will be introduced on following sections.

Note! When you run the configuration utility for the first time, the default device 
name is obtained from the serial device’s MAC identification number. 
The name can be altered through the configuration utility.
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Figure 3.12 Viewing Basic Settings

3.5.3 Network Settings
Prior to setting up the server’s IP address determine the IP address mode.
There are four mode types available:
 Static IP: mode to assign a specific assigned address
 DHCP / AutoIP: mode to automatically assign IP addresses through a DHCP 

server
 BOOTP / AutoIP: mode to automatically assign an IP address through the con-

figuration server
 DHCP/BOOTP/AutoIP: mode to automatically assign an IP address using a 

Bootstrap Protocol or DHCP server.

The server is set with the following default IP configuration:
 10.0.0.1 (Eth1)
 10.0.0.2 (Eth2)

The EKI-1526 Series includes a software utility option, which you can install on your
system, for configuration through computer-based software. The EKI-1526 Series
also includes a web interface option for configuration through a standard web
browser.
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Figure 3.13 Utility Overview

You can choose from four possible IP Configuration modes --- Static, DHCP, BOOTP,
and DHCP/BOOTP.
 

Figure 3.14 Network Settings Overview
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Table 3.5: Network Settings
Item Description

Static IP Static IPUser defined IP address, Subnet Mask, and Default Gate-
way.

DHCP + Auto-IP DHCP Server assigned IP address, Subnet Mask, Default Gate-
way, and DNS.

BOOTP + Auto-IP BOOTP Server assigned IP address.

DHCP + BOOTP +  
Auto-IP

DHCP Server assigned IP address, Subnet Mask, Default Gate-
way, and DNS, or BOOTP Server assigned IP address. (If the 
DHCP Server does not respond)

DNS Setting

In order to use DNS feature, you need to set the IP address of the 
DNS server to be able to access the host with the domain name. 
The EKI-1526 Series device server provides Primary DNS Server 
and 
Secondary DNS Server configuration items to set the IP address of 
the DNS server. Secondary DNS Server is included for use when 
Primary DNS server is unavailable.

DHCP Advanced Set-
ting

When you enabling DHCP protocol to get IP address, it will be 
waited DHCP server to give IP within DHCP time out. The default 
value is 180 seconds.

Note! When you have finished the configuration of these settings for each cat-
egory, please press the “Apply” button in order to make these settings 
effective on the Serial Device Server.



EKI-1526 User Manual 26

3.6 Administrator Settings
3.6.1 Locate the Serial Device Server

When several serial device servers are connected to the network, identification of a
specific serial device is possible through the Locate function.
To locate the serial device server:
1. From the device list frame, locate the desired device and right-click on it to dis-

play the settings menu.
2. Select Locate from the menu.

Figure 3.15 Locate the Serial Device Server

The unit’s Status LED will turn solid amber and the buzzer will sound until you click
Stop Locate.

3.6.2 Securing the Serial Device Server

3.6.2.1 Lock the Serial Device Server
The configuration utility provides the “Lock Device” function to make it more secure.
To lock the serial device server:
1. Right-click a desired device to display the settings menu.
2. Select Lock Device.
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Figure 3.16 Lock the Serial Device Server

3. Enter a password. Retype the password entry to confirm the profile password.
 

Figure 3.17 Enter a Password

4. Right-click a desired device to display the settings menu. Select Reset Device to 
restart the serial device server and store your setting password into the memory.
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Figure 3.18 Reset Device

3.6.2.2 Unlock the Serial Device Server
To unlock the serial device server:
1. Right-click a desired device to display the settings menu.
2. Select Unlock Device.
3. Enter the password as entered in the Lock Device procedure.
 

Figure 3.19 Unlock the Serial Device Server

If you forgot the password, you must restore the setting of the serial device server to
the factory defaults, which will be introduced in the next section.
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3.6.3 Restore to Factory Default Settings
The configuration utility provides the function to restore the serial device server to
factory default settings. 
 

Figure 3.20 Restore to Factory Default Settings

The confirm message will display after clicking Restore to Factory Default Settings. If
you really want to restore the serial device sever to factory default settings, please
click Yes button to continue.
Power off the serial device server within ten seconds. After reconnecting the power,
all settings will be reset to the factory default. If the power supply remains connected
for more than ten seconds, the serial device server will not be changed.

3.6.4 Resetting the Device
The Reset Device is available to allow you to reset the serial device server. The
function disconnects both the Ethernet and serial connections.
The function also allows the serial device server to save new configuration settings to
flash memory. Once a new setting is changed, you can use the Save function to
accept the changes. You will need to reset the device to save the settings to flash
memory.
To reset the device:
1. Right-click a desired device to display the settings menu.
2. Select Reset Device.
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Figure 3.21 Reset Device

The device resets. Once the process is complete, the serial device server displays
under the Serial Device Server listing once again.

3.6.5 Add to Favorite
The Add to Favorite function allows to easily map available devices to Favorite’s. By
bookmarking specific devices, you can create quickly accessible shortcuts for exist-
ing critical devices from the vast pool of locally or remotely networked EKI-1526
Series devices.
 

Figure 3.22 Add to Favorite
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3.6.6 Auto Mapping
See “Auto Mapping” on page 44 for further details.

3.6.7 Manual Mapping
See “Manual Mapping” on page 46 for further details.

3.7 Create CA
Generate the Certificates by EKI Utility on Windows 

1. Check System Settings
Right-click This PC and select Properties. This will open the System page in the Con-
trol Panel. Alternative methods may also be used. 

2. Advanced System Settings
In the System page, click Advanced System Settings. Navigate to the Advanced tab
and click Environment Variables.

3. Modify Environment Variables
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4. Generate Certificates Using EKI Utility
After adding the environment variable, open EKI Utility and go to Tools > Create
CA.
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Select the folder to store the generated certificate files. Select a folder to store the
generated certificate files.
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Chapter 4
4 Selecting An 
Operating Mode
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4.1 Overview
The EKI-1526 Series is designed to network-enable any RS-232/422/485 serial
device, an provides industry-grade hardware and easy-to-use software to make con-
necting serial devices to an Ethernet network a surprisingly simple process.
These units immediately upgrade your existing serial devices for integration into the
Internet world. The EKI-1526 Series features many powerful functions, such as high-
speed data transfer, access-control, auto-detection of all EKI-1526 Series products,
and more.
After the simple installation steps to attach your network and serial device to the
appropriate connectors on the serial device servers and driver installation, you will be
able to communicate with the serial devices via its own application software and with
the EKI-1526 Series device server. COM port redirector, USDG TCP server mode,
TCP client mode, UDP server mode, UDP client mode, RFC2217 mode are all differ-
ent methods of making a serial connection across using one or more serial device
servers.

4.2 COM Port Redirector (Virtual COM Port)
Advantech EKI Device Configuration Utility is a serial COM port redirector that cre-
ates virtual COM ports and provides access to serial device connected to Advantech
serial device server. You can configure the serial device server and enable the Virtual
COM port using one integrated utility. Advantech EKI Device Configuration Utility
allows you to configure Microsoft applications to communicate with network enabled
serial device servers as easily as if they were physically installed in or directly con-
nected on the PC. 
The Advantech redirector can create up to 255 virtual COM ports. Application to the
host can open a virtual COM port to access the serial device servers at the same
time. The redirector will handle each active virtual COM port as a separate TCP con-
nection to Advantech serial device servers.
 

Figure 4.1 Virtual COM Mode
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The EKI-1526 Series provides Multi-access function through an Ethernet connection
path, allowing a maximum of five connections to open one serial port simultaneously.
In this mode all connections must use the same serial setting. If one serial setting
within this configuration is configured differently, the data communication will not
function correctly.

Figure 4.2 Configuring Virtual COM Mode

The Host Idle Timeout setting monitors the connection between the host and the
device. If the Host Idle Timeout setting time is reached, the device server will release
the resources allocated to the port mapping. This prevents a stalled host from affect-
ing the connective device.

The Multi-access function has two modes. One is Normal mode and the other is
Round-Robin mode.

4.2.1 Normal Mode
By setting the Response Timeout parameter to 0, the EKI-1526 Series will operate in
normal mode. When multiple hosts simultaneously open the serial port, only the first
connected host obtains management control; the remaining connections have data
communication functionality only. Each serial port supports up to five simultaneous
connections, allowing multiple hosts to transmit and receive data through the same
serial port at the same time. Every host can transmit data to the same serial port, and
the EKI-1526 Series will also transmit data to every host. When multiple hosts trans-
mit data to the same serial port simultaneously, the received data from Ethernet and
the serial port outputs are mixed. When the EKI-1526 Series receives data from the
serial port, it transmits the data to all connected hosts simultaneously.

4.2.2 Round-Robin Mode
If the Response Timeout value is between 0 and 65,535, the EKI-1526 Series oper-
ates in Round-Robin mode. Each serial port supports up to five simultaneous con-
nections, allowing hosts to transmit and receive data through the same serial port at
the same time. Every host can transmit data to the same serial port, and the EKI-
1526 Series processes the data in the order it arrives. The EKI-1526 Series pro-
cesses the first host’s request and replies. The serial device server determines the
end of the serial acknowledgment through a response timeout.

Note! The default value of "Host Idle Timeout" is 60 seconds.
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When the EKI-1526 Series serial device server does not receive a response from the
serial port after a response timeout query, the device replies with an acknowledgment
and then processes the next host request. With an increased number of hosts,
response time may be lengthy, increasing the Response Timeout period.

Frame Break is an important parameter for Round-Robin mode. It is a smart method
for reducing ineffective waiting periods and streamlining the transmission process.

If the Frame Break function is disabled, EKI-1526 Series devices will wait for a
Response Timeout period, whether or not the device has transmitted data. During
this period, host commands are queued and processed in the order received.

If Frame Break is enabled and the serial port remains idle longer than the Frame
Break period, the EKI-1526 Series assumes the communication is complete and con-
tinues with the next query. This is an efficient way to reduce waiting time and improve
performance..

4.3 USDG Data Mode
The EKI-1526 Series can function as either a Data TCP server or a Data TCP client.
Both operations support TCP and UDP protocol. The EKI-1526 Series allows you to
treat your serial devices as if they were networking devices. You can issue com-
mands or transmit data from serial devices, connected to a EKI-1526 Series device,
to any devices that are connected to the Internet.

4.3.1 USDG TCP Client Mode
In TCP Client mode, the TCP connection is established from the EKI-1526 Series
device server. This operation mode supports a maximum of 16 simultaneous connec-
tions for each serial port on the EKI-1526 Series, either to a single host or multiple
hosts. You can configure the IP address and TCP port number of the network hosts
connected to the EKI-1526 Series device server using the Advantech Serial Device
Server Configuration Utility.
After configuring the devices, when the EKI-1526 Series device server receives data
from the serial port, it connects to the configured hosts.

Note! The Respond Timeout is used in some multiple access applications, for 
applications with single access by a TCP client, this option is not 
needed.
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Figure 4.3 USDG TCP Client Mode

In USDG Data TCP Client mode, you may need to enable the peer numbers you
would like to receive. You can set a maximum sixteen network devices to which you
may connect. You need to fill out the IP Address and Port (including local port and
peer port) of each network device to which you want to connect. 
In the Peer for Receiving Data menu, entering “0” as the value for the Local Port will
assign a random TCP Port for an EKI-1526 Series device.

Figure 4.4 Peers for Receiving Data

4.3.2 USDG Data TCP Server mode
In TCP server mode, the TCP connection is initiated from the host to the EKI-1526
Series device server. This operation mode supports a maximum of five simultaneous
connections for each serial port on an EKI-1526 Series device server from a single or
multiple hosts. However, a multi-host connection simultaneously transmits the data
from a single serial port.
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Figure 4.5 USDG TCP Server Mode

Figure 4.6 USDG Data Mode

4.3.3 USDG UDP Server/Client Mode
The USDG UDP mode is primarily used for the broadcasting of messages over a net-
work. In UDP server mode, data is transmitted from the Host connected to the EKI-
1526 Series USDG UDP Port (Default Port 5300). In the default UDP client mode,
EKI-1526 Series device servers simultaneously transmit UDP messages to a maxi-
mum of 16 peers.
For detailed information on USDG Data Mode features and settings, please refer to
Chapter 6: Web Interface Port Configuration > Port 1 (or Port 2) Operation > USDG
Data Mode page (6.7.22).
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4.4 USDG Control Mode
In controlling mode, the EKI-1526 Series device server presents a modem interface
to the attached serial device: it accepts AT-style modem commands to connect / dis-
connect to other networking device. 
If you want a serial device running application program to connect/disconnect to dif-
ferent devices on request, this function is available through the USDG Control mode.

Figure 4.7 USDG Control Mode

4.4.1 Hangup Character
The default character is “+”. After you have connected to another serial device an via
EKI-1526 Series device, you may need to disconnect, using the command “+++”. To
do this, press “+” three times and wait for the Guard timeout <default value is
1000ms>; the device will disconnect. You can set “Guard Time” to define the idle
time.
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4.4.2 Guard Time
The default value is 1000 ms. 
Example: <Guard Time>+++<Guard Time> 

4.5 RFC2217 Mode
RFC2217 mode is similar to virtual COM mode in that a driver is used to establish a
transparent connection between a host computer and a serial device by mapping the
serial port on EKI-1526 Series devices to a local COM port on a host computer.
RFC2217 defines general COM port control options based on the Telnet protocol.
Third party drivers supporting RFC2217 are widely available on the Internet and can
be used to implement virtual COM mapping to the serial port of your device.

4.6 SSH Console Mode
SSH console mode is designed to expose the serial console interface via SSH proto-
col; this function allows users to set up out-of-band management for network
switches routers and firewalls. It can also be helpful for building test beds for central-
ized research and development labs.

Table 4.1: Guard Time
Command Function

ATD <IP address><TCP port><CR>

Forms a TCP connection to the specified host.
Ex: ATDT 192.0.55.22:5201
In above example, the EKI-1526 Series device 
server forms a raw TCP connection to the networking 
device (192.0.55.22). The TCP port is 5201.

ATA <CR> Answering an incoming call

+++<CR>
Returns the user to the command prompt when 
entered from the serial port during a remote host 
connection.

<LF><CR> OK <LF><CR> Commands are executed correctly
<LF><CR> CONNECT <LF><CR> Connect to other device
<LF><CR> RING ddd.ddd.ddd 
<LF>< CR>

Detect the connection request from other device, 
which IP address is ddd.ddd.ddd.ddd.

<LF><CR> DISCONNECT 
<LF><CR> Disconnect from other device

<LF><CR> ERROR <LF><CR> Incorrect commands

<LF><CR> FAIL <LF><CR> If you issue an ATDT command and can not connect 
to the device, it will response “FAIL”.



Chapter 5
5 Setting up Virtual COM
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5.1 Setting COM Port Redirector
Advantech COM port mapping software is a serial COM port redirector that creates
virtual COM ports and provides access to serial devices connected to an Advantech
serial device server. Your serial device applications can communicate with serial
devices connected to the Advantech serial device servers without software changes.
Since the virtual COM ports work like standard Windows COM ports, your application
software sees no difference between a local serial device and one connected to an
Advantech serial device server.
The COM redirector utility and the virtual COM port management utility are integrated
into one utility with same GUI. The Advantech Serial Device Server Configuration
Utility can create all Virtual COM ports using the Auto Mapping function or by using
the manual mapping function.

5.2 Virtual COM Port Mapping
5.2.1 Auto Mapping

1. On your desktop, navigate to Start > EKI Device Configuration Utility and 
click Advantech EKI Device Configuration Utility to open the utility.

2. Under Serial Device Servers, locate your server and click the icon to expand the 
listing.

3. Select the target device and right-click on it to open up the options menu win-
dow.

4. Locate Auto Mapping and select it. 
 

Figure 5.1 Selecting Auto Mapping

The Batch Automatic Mapping Virtual COM Port window displays.

5. Locate From System Port and click the drop-down menu to select the target 
COM port.
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6. From the network address list, select the address options to map.

The selected address displays the Device Port and (EKI-1526 Series device server
physical serial port) and the system port which will be the VCOM port for the PC.
 

Figure 5.2 Selecting Auto Mapping 

7. From the network address list, select the address options to map.
8. Click Map Selected Ports to set the configuration.
 

Figure 5.3 Mapping Selected Ports

Once the mapping function is initialized, a successful mapping process results in the
virtual mapping of the designated physical serial port and VCOM PC port. See the
following figure.
 

Figure 5.4 Viewing VCOM Mapping Results
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5.2.2 Manual Mapping
1. On your desktop, navigate to Start > Configuration Utility and click utility.
2. Under Serial Device Servers, locate your server and click the icon to expand the 

listing.
3. Select the target device and right-click on it to open up the options menu win-

dow.
4. Locate Manual Mapping and select it. 
 

Figure 5.5 Selecting Manual Mapping

The Manual Mapping Virtual COM Port window displays.
5. In the Device > Serial Port drop-down menu, select the target port to map. This 

is the physical serial port on the EKI-1526 Series device.
6. In the Host > COM Port drop-down menu, select the target COM port to map. 

This is the virtual port on the target PC.
 

Figure 5.6 Viewing Manual VCOM Mapping Results
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7. Click Map it to continue the process. The mapping process may require a short 
time. Once this step is completed, the Manual Mapping Virtual COM Port win-
dow displays again to map the VCOM port on the target PC.
Once the mapping function is initialized, a successful mapping process results 
in the virtual mapping of the designated physical serial port and VCOM PC port. 
See the following figure.

Figure 5.7 Viewing Manual VCOM Mapping Results

To allow for an automatic connection after a reboot or a power up, click the Auto
Reconnect option to enable this function.

5.2.3 Configuration Wizard
1. On your desktop, navigate to Start > EKI Device Configuration Utility and 

click Advantech EKI Device Configuration Utility to open the utility.
2. Under Serial Device Servers, locate your server and click the icon to expand the 

listing.
3. From the tool bar, select Configuration Wizard. 
 

Figure 5.8 Selecting the Configuration Wizard 

The Wizard screen displays and lists available devices.
4. Select the target device and click Next to continue.The Wizard Device Settings 

window displays.
5. Under Serial Port Settings, click the Type drop-down menu and select the port 

type.Review the settings under the Ethernet fields and verify them.
6. Click Next to continue or Previous to return to the previous screen. The 

selected settings are displayed in the following Wizard window.
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7. Locate the radio button correlating to the target port to modify and click on it to 
select it. Verify the Device Port (EKI-1526 Series device physical serial port) and 
System Port (virtual COM port for PC) settings before continuing.

8. Click Finish to complete the process. A Wizard complete! screen displays indi-
cating the completion of a successful procedure.

5.2.4 Confirming Virtual COM Settings
1. On your desktop, navigate to Start > EKI Device Configuration Utility and 

click Advantech EKI Device Configuration Utility to open the utility.
2. Locate Serial Ports menu in the menu pane and click on the Expand icon next to 

Virtual COM Ports to view a list of the mapped ports.
3. Select a VCOM port to view its settings.
 

Figure 5.9 Serial Port Listing on EKI-1526 Series Device

For the next step, you will need to open the device manager on your system. Using
the Device Manager, you can both view and change the COM port settings.

4. On your desktop, click on the Start button and then on Control Panel. A win-
dow displays showing all the available control panels.

5. Click on Hardware and Sound (Hardware). A list of all available hardware con-
figuration options displays. 

Note! The following instructions were developed in a Windows 7 environment; 
the Windows XP equivalent is displayed in parentheses (). Instructions 
may vary according to the operating system used.
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6. Under Devices and Printers, click on the Device Manager link. A new window 
displays showing a list of all the available devices on your computer.

7. Locate Ports (COM & LPT) and click on the expand icon. A list of all available 
serial and parallel port devices display. 

The newly mapped VCOM port should be listed under the same mapped settings
used in the previous steps.

Figure 5.10 System Port VCOM Mapping Configuration

The newly mapped VCOM port is listed under the same mapped settings used in the
previous steps. The settings correspond to the VCOM port configuration on the EKI-
1526 Series device, see the following figure.
 

Figure 5.11 Verifying VCOM Mapping Configuration

If the settings do not correspond, the VCOM mapping is not correct. See “Virtual
COM Port Mapping” on page 62 to re-map the VCOM ports.
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5.2.5 Removing VCOM Ports
1. On your desktop, navigate to Start > EKI Device Configuration Utility and 

click Advantech EKI Device Configuration Utility to open the utility.
2. Under Serial Ports, click the expand icon on Virtual COM Ports to view the con-

figured port list.
3. Locate the port to remove and right-click on it to open the options menu.
4. Scroll down to Remove This Port and click on it to initiate the procedure.
 

Figure 5.12 Remove VCOM Port

A Remove Port confirmation window displays.
5. Click OK to continue with the removal process or Cancel to return to the previ-

ous menu.
Once the procedure is completed, a prompt displays the successful removal of 
the port from the VCOM mapping list.

5.2.6 Exporting and Importing VCOM Mapping
Importing and exporting Virtual COM Port Mapping is useful when the factory has
already used a number of serial device servers in VCOM mode. You can easily
upgrade to a new utility, and don’t need to re-map the Virtual COM Ports. For exam-
ple, when you would like to upgrade from Utility 1.71 to Utility 3.0, you can export
your own mapped Virtual COM Ports in Utility 1.71 and save them as a *.cpm file.
After upgrading to Utility 3.0, import your *.cpm file and restore your own Virtual COM
Ports.

Note! This Virtual COM Port Mapping tool can only recover Virtual COM Ports 
that have been mapped previously. For newly installed serial device 
servers, please follow the virtual COM Port mapping steps.
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1. On your desktop, navigate to Start > EKI Device Configuration Utility and 
click Advantech EKI Device Configuration Utility to open the utility.

2. Locate Serial Ports menu in the menu pane and click on the Expand icon next to 
Virtual COM Ports to view a list of the mapped ports.

3. Select a VCOM port.
4. Click Import Virtual COM Port Mapping or Export Virtual COM Port Mapping in 

the File menu.

5.3 Running a Diagnostic Test
The loopback test allows you to determine if the EKI-1526 Series device server is
configured correctly to identify any failed nodes in the network. The test allows you to
send a signal from the server and return (looped back) it back to the server.
1. Connect the loopack connector to a COM port on the EKI-1526 Series device 

server.
2. On your desktop, navigate to Start > EKI Device Configuration Utility and 

click Advantech EKI Device Configuration Utility to open the utility.
3. Under Serial Ports, click the expand icon on Virtual COM Ports to view the con-

figured port list.
4. Open the ICOMToolsPlus utility to open the EKI-1526 Series device server set-

tings.
5. Set the COM port configuration to match the Port Configuration.
6. Click the Start menu.

A successful loop back test incrementally displays the Bytes/sec values on both dis-
played menus.
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Chapter 6
6 Web Interface
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6.1 Overview
The EKI-1526 Series serial device server can be configured through a web interface.
By using a standard web browser, the same procedure as with the Windows configu-
ration utility can be used. In the browser’s address field, enter the IP Address of your
EKI-1526 Series serial device server. The default IP setting is 10.0.0.1, but you
should use the IP which you have previously assigned for this device. Once the IP is
entered, you will be presented with the following windows.

6.2 Accessing the Web Page
6.2.1 Accessing the Web Page via Configuration Utility

To access the web page via configuration utility: 
1. Select Ethernet under the desired device.
2. Click Launch Browser.
 

Figure 6.1 Accessing the Web Page via Configuration Utility

Note! Before using the web-based configuration, make sure your host PC 
Ethernet network IP domain is as same as the serial device server, or it 
can establish the TCP connection with the serial device server.

Note! It is recommended that you use Microsoft Internet Explorer 7.0 or 
higher.

Note! Any changes made to the web page functionality will only take effect 
after a reboot.
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6.2.2 Accessing the Web Page via Web Browser
Once the device is installed and connected, power on the device. The following infor-
mation guides you through the logging in process.
1. Launch your web browser on the PC.
2. In the browser’s address bar, type the device’s default IP address (Eth1: 

10.0.0.1, Eth2: 10.0.0.2).
The main menu is shown. 

6.3 System
You can change the Device Name and Device Description on this page. You can also
enable or disable the Telnet and SNMP functions. Moreover, you can set the Time
zone related settings.
To access this page, click System.

Figure 6.2 System

The following table describes the items in the previous figure. 
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Table 6.1: System
Item Description
Firmware Version Displays the current firmware version of the device.
Revision Number Displays the revision number of the device.
Device Name Enter the device name: up to 31 alphanumeric characters.
Device Description Enter the device description.
VCOM Ignore Device 
ID

Click Enabled or Disabled to enable or disable VCOM ignore device 
ID.

Telnet Click Enabled or Disabled to set remote access through the Telnet 
Service function.

SSH* Click Enabled or Disabled to set remote access through the SSH 
Service function.

SNMP Click Enabled or Disabled to define the SNMP daemon.

SSDP
When enabled, the gateway is discoverable on a Windows network. 
When disabled, the gateway is discoverable by the EKI Device Con-
figuration Utility.

Local Time

Enter the year, month, day, hour, minute and second.
 The year must be entered in 4-digit format.
 The time must be entered in 24-hour format.
 All six fields must have values.

Time Server

Enter the address of the SNTP server. This is a text string of up to 64 
characters containing the encoded unicast IP address or hostname of 
a SNTP server. Unicast SNTP requests will be sent to this address. If 
this address is a DNS hostname, then that hostname should be 
resolved into an IP address each time a SNTP request is sent to it.

Daylight Saving 
Time*

To use automatic Daylight-Saving Time adjustment, enable the fea-
ture then select the starting and ending times and time zone offset.

Virtual Gateway Settings

Virtual Gateway*

Virtual Gateway COM Port Redundancy
Interface Select an Ethernet Interface (Eth1/Eth2) 

Virtual IP 

Enter an IP address for the virtual gateway. This 
address will be used to access the group of gateways 
as one device. Enter the same Virtual IP address for 
all devices participating in the virtual gateway. 

ID
Enter a Modbus ID for the Virtual Gateway. Enter the 
same ID for all devices participating in the virtual gate-
way. 

Priority 

Select a priority for this device (i.e., Primary, Second-
ary, Third or Fourth). Only one device will be active at 
any time. If the highest priority device becomes 
unavailable, the next lower priority device will become 
active. 

Save Click Save to save the values and update the screen.
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6.4 Service
The Service tab contains menu options for configuring the VCOM, USD, Web Server,
SSH Console Setting, and RADIUS/LDAP/Local user management.

6.4.1 VCOM
VCOM retains its earlier functionality, along with the advanced VCOM Security fea-
tures. The default is VCOM 2.0 protocol version to  enable new parameters across
several areas of the UI and enhances serial data transmission.

Figure 6.3 VCOM 1.0
 

Figure 6.4 VCOM 2.0

The following table describes the items in the previous figure.

Table 6.2: VCOM
Item Description

VCOM over TLS Click to enable or disable virtual COM using a TLS connection 
encrypts all data sent between serial interface.

Allow Expired Certs Click to enable or disable using expired certificate. However, there 
are many security risks to using an expired SSL certificate.

VCOM Handshake 
Timeout (ms)

Enter the VCOM Handshake Timeout time to ensure a secure con-
nection by preventing TLS handshake errors, as it defines the dura-
tion (ms) a virtual COM port waits for a successful handshake before 
terminating the connection if unsuccessful.

Root CA The Root CA signs certificates that are used to authenticate the 
identity of the devices or servers in a TLS-secured communication.
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6.4.2 USDG
USDG retains its earlier functionality, along with the advanced USDG Security fea-
tures. The default is USDG 2.0 protocol version to enable new parameters across
several areas of the UI and enhances data transmission.
 

Figure 6.5 USDG1.0
 

Figure 6.6 USDG 2.0

Upload Path

Click Browse to select a Root CA public key for the VCOM over TLS.
Click Upload to import the selected file.
Click Delete to remove the selected file.
Click + Show Details to view the details of the selected key.

Key Pair

A Key Pair consists of a private key and a public key.
The public key is embedded in its TLS certificate (signed by a CA), 
and the private key is used to decrypt incoming data encrypted with 
the public key.

Upload Path

Click Browse to select a Key Pair for the VCOM over TLS.
Click Upload to import the selected file.
Click Delete to remove the selected file.
Click + Show Details to view the details of the selected key.

Key Pair Password Enter a password to protect the private key within the Key Pair.

Diffie-Hellman Allows the server and client to securely agree on a shared encryp-
tion key for their session without transmitting it over the network.

Upload Path

Click Browse to select a Key Pair for the VCOM over TLS
Click Upload to import the selected file.
Click Delete to remove the selected file.
Click + Show Details to view the details of the selected key.

Save Click Save to save the values and update the screen.

Table 6.2: VCOM
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The following table describes the items in the previous figure.

6.4.3 Web Server
The EKI-152x web interface uses the unsecure http protocol by default, but can be
configured to use https for added security. When HTTPS is enabled, communication
between the web browser and the EKI device is encrypted using an SSL certificate.
An HTTPS connection is required if you plan to update the device firmware using the
web interface instead of using the utility provided with the firmware.

Table 6.3: USDG
Item Description

USDG over TLS Click to enable or disable virtual COM using a TLS connection 
encrypts all data sent between serial interface.

Verify Client Verify the client's signature.

Allow Expired Certs Click to enable or disable using expired certificate. However, there 
are many security risks to using an expired SSL certificate. 

Command Listen Port

Enter a value to identify the command listen port for accepting con-
nected request of other network device.
Each port has its own command listen port to accept connection 
requests from other network devices, so the command listen port 
cannot be set to the same value. The Command Listen Port is dif-
ferent from the Data Listen port. <Default Port is 5400>

Root CA The Root CA signs certificates that are used to authenticate the 
identity of the devices or servers in a TLS-secured communication.

Upload Path

Click Browse to select a Root CA public key for the USDG over 
TLS.
Click Upload to import the selected file.
Click Delete to remove the selected file.
Click + Show Details to view the details of the selected key.

Key Pair

A Key Pair consists of a private key and a public key.
The public key is embedded in its TLS certificate (signed by a CA), 
and the private key is used to decrypt incoming data encrypted with 
the public key.

Upload Path

Click Browse to select a Key Pair for the USDG over TLS.
Click Upload to import the selected file.
Click Delete to remove the selected file.
Click + Show Details to view the details of the selected key.

Key Pair Password Enter a password to protect the private key within the Key Pair.

Diffie-Hellman Allows the server and client to securely agree on a shared encryp-
tion key for their session without transmitting it over the network.

Upload Path

Click Browse to select a Diffie-Hellman for the USDG over TLS.
Click Upload to import the selected file.
Click Delete to remove the selected file.
Click + Show Details to view the details of the selected key.

Save Click Save to save the values and update the screen.
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Figure 6.7 Web Server

The following table describes the items in the previous figure.

Table 6.4: Web Server
Item Description

Protocol
Choose HTTP, HTTP + HTTPS, or HTTPS Only for the web server, with 
HTTPS offering secure, encrypted communication through valid certifi-
cates.

TLS Verify
The TLS Verify function is required for the HTTPS protocol; select Ver-
ify Client for mutual authentication, or None if this function is not 
needed.

Certificate After enabling https support, choose a .pem file containing your SSL 
certificate and click Upload.

Private Key After enabling https support, choose a .pem file containing your private 
key and click Upload. 

Root CA After enabling HTTPS support, uploading Root CA to securely establish 
an HTTPS connection.

Save Click Save to save the values and update the screen.

Device Protect
Set a password to enable the Device Protect function, which encrypts 
the device configuration file; after activation, the export and import 
functions will display a lock icon. (Please keep the password)
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The SSH Console Setting function allows for the setup of the system wide configura-
tions related to the SSH console service.
 

Figure 6.8 SSH Console Setting

6.4.5 LDAP and RADIUS Setting
The gateway can use the LDAP protocol or RADIUS protocol for user management,
or user management can be controlled locally. Setting up LDAP or RADIUS integra-
tion is an advanced topic with security implications. We recommend that the LDAP or
RADIUS setting be configured by your network administrator.

Note! HTTPS will not work without a certificate and private key and Root CA. 
The SSL certificate and private key should both be contained in one 
.pem file.
Upload the same file as both Certificate and Private Key.
(Refer to Section 3.7 Create CA or Section 6.11.2 Certs Generator for 
certificate generation methods.)

Note! Generate the Certificates by EKI Utility on Windows. EKI Utility version 
should be v3.07 or later to support this function.

Note! All new configurations will take effect after rebooting. To reboot the 
device, click Tools > Reboot.

Table 6.5: SSH Console Setting
Item Description
Host Key Click Regenerate to reissue the CA key for the SSH console service. 
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6.4.6 LDAP Setting
 

Figure 6.9 LDAP Setting

The following table describes the items in the previous figure.

Table 6.6: LDAP Setting
Item Description
LDAP Server Enter the string to indicate the IP address or DNS of the LDAP server.

LDAP Key Enter the string to indicate the user name prefix to define the LDAP 
DN key.

LDAP Timeout Enter the string to indicate the interval period between permission 
updates for each SSH connection.

LDAP Rapid
Enter the string to indicate the interval period between permission 
checks when the device detects a permission change on a SSH con-
nection.

LDAP over TLS Click to enable (default) or disable the LDAP over TLS function.
Root CA

Upload Path

Click Browse to select a Root CA public key for the LDAP server.
Click Upload to import the selected file.
Click Delete to remove the selected file.
Click + Show Details to view the details of the selected key.

Access Setting
Port Displays the port number of the access setting.

Config DN Displays the DN of the directory, which holds users with permission to 
configure basic functions of this serial interface

Save Click Save to save the values and update the screen.
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6.4.7 RADIUS Setting
 

Figure 6.10 Radius Setting

The following table describes the items in the previous figure.

6.4.8 User Management
Users can be managed via LDAP, Radius or Local user management settings. If local
user management is used, the user list is managed from this screen. A Web
Enhanced Password must be set on the Passwords page in order to activate user
management. That web password will show up on this page as the ‘root’ user.

Table 6.7: Radius Setting
Item Description

Radius Server IP Address Enter the string to indicate the value for the address of the 
RADIUS server.

Radius Server Port Enter the string to indicate the port for the RADIUS server.
Radius Server Secret 
Passphrase

Enter the string to indicate the passphrase used by the 
Radius server.

Radius Server EAP Type

Click the drop-down menu to select the value for the EAP 
type of the Radius server. Options: 
 MD5 
 PEAP 
 TTLS

Radius Timeout Enter the string to indicate the periodic time period used for 
checking with the RADIUS server.

Radius Super User Header Highest authority user header
Access Setting
Port Displays the port number of the access setting.

Config DN Displays the DN of the directory, which holds users with per-
mission to configure basic functions of this serial interface

Save Click Save to save the values and update the screen.
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Figure 6.11 User Management

The following table describes the items in the previous figure.

Table 6.8: User Management
Item Description

Method LDAP, Radius or Local User. The remaining settings on this page is only 
relevant when Local User is selected.

Local 
Timeout

The system will check the privilege settings for all connected users on this 
timeout interval. If there’s a privilege change (e.g., the user is no longer 
allowed), the user will be disconnected.
A new user logging in will trigger a privilege check of all connected users 
immediately regardless of the Timeout value.

Local Rapid
When the system discovers a privilege change, it will wait for the Rapid 
interval to check all users again, and will continue until all connected users 
have the correct privilege

Local User 
Access 
Settings 

When the system discovers a privilege change, it will wait for the Rapid 
interval to check all users again, and will continue until all connected users 
have the correct privilege 

Add Add a new local user. Specify username and password, 
and enable/disable the Config attribute for each port. 

Edit Modify the password or attributes for an existing user. 
Delete Remove an existing user. 
Username Enter a user name. 
Password Enter a password. 

Attribute 
Enable each port that this user should be able to config-
ure. A user must have config permission on at least one 
port in order to save the username in this list. 

Save Click Save to save the values and update the screen.

Note! All new configurations will take effect after rebooting. To reboot the 
device, click Tools > Reboot. 
Changing user management setting may cause you to lose access to 
the device! Make sure you have access permissions with your new set-
tings.
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6.5 Ethernet Configuration
Choose either Eth 1 or Eth 2 (EKI-1211 only has Eth 1) in the Ethernet Configuration
page. Enter the corresponding values for your network environment. Remember to
press Save after entering all values. To access this page, click Ethernet Configura-
tion.

Figure 6.12 Ethernet Configuration

The following table describes the items in the previous figure.

Table 6.9: Ethernet Configuration
Item Description
IPv4 Configuration

Mode

Select the IP Address Setting mode:
 Static IP - Set a fixed IP configuration
 DHCP/AutoIP - IP configuration set by DHCP server
 BootP/AutoIP - IP configuration set by BOOTP server
 DHCP/BootP/AutoIP - accept IP configuration from either 

DHCP or BOOTP server
Bridge - set up a bridge connection between the two Ethernet ports

MAC Address Enter the MAC address to which packets are statically forwarded.

IP Address Enter a value to specify the IP address of the interface.
The defaults are: Eth1, 10.0.0.1; Eth2, 10.0.0.2.

Subnet Mask Enter a value to specify the IP subnet mask for the interface. The 
default is 255.0.0.0.

Default Gateway Enter a value to specify the default gateway for the interface
DNS Configuration

DNS

 Automatic: Get DNS server assignment from the DHCP 
server (no DNS will be assigned if the Mode is set to Static 
IP)

 Specific: Enter primary and secondary DNS server addresses
Current Status
IP 1 Displays the current IP address 1 of the device.
IP 2 Displays the current IP address 2 of the device.
Save Click Save to save the values and update the screen.
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6.6 Ethernet Bridge
In Ethernet Bridge mode, both Ethernet interfaces use the same IP address. Either
Spanning Tree Protocol (STP) or Redundancy Mode can be used to prevent loops
and provide a backup communications path.
 

Figure 6.13 Ethernet Bridge Configuration

The following table describes the items in the previous figure.

Note! All new configurations will take effect after rebooting. To reboot the 
device, click  Tools > Reboot.

Table 6.10: Ethernet Bridge
Item Description
IPv4 Configuration
Mode Static IP is the only valid option for the Ethernet Bridge. 
MAC Address Enter the MAC address to which packets are statically forwarded.

IP Address Enter a value to specify the IP address of the interface. The 
default is 10.0.0.3. 

Subnet Mask Enter a value to specify the IP subnet mask for the interface. The 
default is 255.0.0.0. 

Default Gateway Enter a value to specify the default gateway for the interface. 
Spanning Tree Protocol 
Configuration

STP
Enable to use Spanning Tree Protocol to control which Ethernet 
port is active. All devices on the network build a spanning tree and 
determine which ports should be blocked to prevent loops.

Redundant Mode Enable to let the EKI-152x control which Ethernet port is active. 
The

DNS Configuration
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6.7 Port Configuration
The serial port configuration menu has Basic, Operation Mode, and Advanced Set-
tings.

6.7.1 Basic
The Basic menu allows for the configuration of the serial interface type, baud rate,
parity, data / stop bits, and flow control for port configuration. To access this page,
click Port Configuration > Basic.

Figure 6.14 Port Configuration > Basic 

The following table describes the items in the previous figure.

DNS Click the radio button to select the DNS mode: Automatic or Spe-
cific.

Current Status
IP 1 Displays the current IP address 1 of the device.
Save Click Save to save the values and update the screen.

Note! All new configurations will take effect after rebooting. To reboot the  
device, click Tools > Reboot.

Table 6.10: Ethernet Bridge

Table 6.11: Basic
Item Description
Type Click the drop-down menu to select a serial interface: RS232, RS422, 

RS485 or RS485 4-WIRE
Baud Rate Enter a value to specify the baud rate. The value should conform to the 

current transmission speeds of connected devices when setting the 
baud rate.

Parity Click the drop-down menu to select the parity: None, Odd, Even, Mark 
or Space.

Data Bits Click the drop-down menu to select the data bits: 5, 6, 7, or 8.
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6.7.2 Operation
The operation menu allows for the configuration of the mode type and related attri-
butes for port configuration.
To access this page, click Port Configuration > Operation.

6.7.2.1 Virtual COM Mode
 

Figure 6.15 Port Configuration > Operation 

The following table describes the items in the previous figure.

Stop Bits Click the drop-down menu to select the stop bits: 1, 1.5 or 2.
Flow Control Click the drop-down menu to select the flow control mode: None, Xon/

Xoff, RTS/CTS
Save Click Save to save the values and update the screen.

Table 6.11: Basic

Table 6.12: Virtual COM Mode
Item Description

Mode
Click the drop-down menu to select the port configuration mode: 
Virtual COM Mode, USDG Data Mode, USDG Control Mode, 
RFC2217 Mode or SSH Console Mode

Host Idle Timeout(s) Enter a value to define the host idle timeout period.
Serial Scheduling
Response Timeout(s) Enter a value to define the response timeout period.
Serial RX Frame
Character Timeout Enable or disable to send pack immediately by character-timeout.
End Character (HEX) Click the option to send pack immediately by end-character.
Length The length to request for Serial RX Frame
Break Time (ms) Enter a value to specify the frame break time.
Serial Data Forwarding
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6.7.2.2 USDG Data Mode
 

Figure 6.16 Port Configuration > Operation > USDG Data Mode

The following table describes the items in the previous figure.

Serial RX Forwarding

Unicast or multicast data from the serial device to one or multiple 
host computers, and the serial device can also receive data from 
one or multiple host computers, making this mode ideal for mes-
sage display applications.

Serial Token Idle 
Timeout(ms)

Enter a value for serial communication will wait without receiving 
any data or tokens before it considers the communication idle or 
inactive.

TX Broadcast

Enable or Disable TX Broadcast to transmit data from one device 
and broadcast it to multiple destinations or devices over a serial 
communication interface. 
Multicast: All devices in the network can see the data.
Unicast: Only the devices connected to the PC can see the data.

Table 6.12: Virtual COM Mode
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Table 6.13: USDG Data Mode
Item Description
Protocol Click the drop-down menu to select the protocol: TCP or UDP.
Data Idle Timeout (s) Enter a value to define the data idle timeout period.

Data Listen Port Enter a value to identify the channel for remote initiating connec-
tions.

Telnet IAC Enable Telnet IAC to allow USDG to support Telnet without pro-
ducing garbled characters.

TCP User Timeout (s)
Enter a value for the TCP connection will wait before determining 
that a data transmission has failed due to a lack of acknowledg-
ment. 

Keepalive
If Disabled, the gateway assumes the host is always available. 
If Enabled, the following settings control the TCP Keep Alive func-
tion. 

Keep Idle Time (s) When no data is transmitted over this interval, initiate the Keep 
Alive function 

Keep Interval (s) When Keep Alive is activated, send a TCP Keep Alive message at 
the specified interval. 

Keep Count Disconnect with the host after the specified number of consecutive 
TCP Keep Alive requests fail to receive a response. 

Serial Scheduling
Response Timeout(s) Enter a value to define the response timeout period.
Serial RX Frame
Character Timeout Enable or disable to send pack immediately by character-timeout.
End Character (HEX) Click the option to send pack immediately by end-character.
Length The length to request for Serial RX Frame
Break Time (ms) Enter a value to specify the frame break time.
Serial TX Frame
End Character (HEX) Click the option to send pack immediately by end-character.
Length The length to request for Serial RX Frame

Modbus RTU 
Command

Enable or disable sending Modbus RTU commands to a Modbus 
RTU end device, with data parsed according to the Modbus com-
mand format to ensure proper interpretation.

Serial Data Forwarding

Serial RX Forwarding

Unicast or multicast data from the serial device to one or multiple 
host computers, and the serial device can also receive data from 
one or multiple host computers, making this mode ideal for mes-
sage display applications.

Serial Token Idle 
Timeout(ms)

Enter a value for serial communication will wait without receiving 
any data or tokens before it considers the communication idle or 
inactive.

TX Broadcast

Enable or Disable TX Broadcast to transmit data from one device 
and broadcast it to multiple destinations or devices over a serial 
communication interface. 
Multicast: All devices in the network can see the data.
Unicast: Only the devices connected to the PC can see the data.

Transmit Target Peers

Peer Number Click the drop-down menu to select the number of network device 
which you want to connect. Maximum is 16 network devices.
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6.7.2.3 USDG Control Mode
 

Figure 6.17 Port Configuration > Operation > USDG Control Mode

The following table describes the items in the previous figure.

6.7.2.4 RFC2217 Mode
 

Figure 6.18 Port Configuration > Operation > RFC2217 Mode

The following table describes the items in the previous figure.

Table 6.14: USDG Control Mode
Item Description
Protocol TCP protocol of the USDG control mode.
Data Idle Timeout (s) Enter a value to define the data idle timeout period.

Data Listen Port Enter a value to identify the channel for remote initiating connec-
tions.

Hang up Character

The default character is “+”. After you have connected to another 
serial device via an EKI device, you may need to disconnect, using 
the command “+++”. To do this, press “+” three times and wait for 
the idle timeout <default value is 100ms>; the device will discon-
nect. You can set “Guard Time” to define the idle time.

Guard Time (ms) Enter a value to identify the guard time.

Table 6.15: RFC2217 Mode
Item Description

Listen Port Enter a value to identify the channel for remote initiating connec-
tions.

Host Idle Timeout (s) Enter a value to define the host idle timeout period.
Save Click Save to save the values.
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6.7.2.5 SSH Console Mode
If not configured, the account can only log in via HTTPS. If configured, it allows for
permission management on the serial port.
LDAP, RADIUS, or local user authentication methods can be used for SSH logins. 

Figure 6.19 Port Configuration > Operation > SSH Console Mode

The following table describes the items in the previous figure.

6.8 Monitor
The EKI-1526 Series device server allows monitoring of the serial ports’ status. The
serial port’s operation mode and status is available for display. The IP address of the
host PC which is communicating with serial port is also displayed.
The Monitor function provides a method to monitor the serial device server’s status
(operation mode, baud rate, data bits, stop bits, parity and RTS/XON/DTR).
Monitoring information is divided into three main message types: Setting/Statistic/
Connected IP.

6.8.1 Setting (VCOM 1.0)
The Monitor Setting page allows for easy viewing of the port’s statistics. To access
this page, click Monitor > Setting.

Figure 6.20 Monitor > Setting

Table 6.16: SSH Console Mode
Item Description

Listen Port

In the Listen Port field, enter a value to bind the TCP port to the value. In 
the following figure a SSH client example is shown displaying the speci-
fied Port destination as configured in the Listen Port setting. To connect 
the EKI, the SSH client must also be configured to use TCP port 5600.

Save Click Save to save the values.
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The following table describes the items in the previous figure.

6.8.2 Statistic (VCOM 1.0)
The Monitor Statistic page allows for easy viewing of the port’s TX/RX data count. To
access this page, click Monitor > Statistic.
 

Figure 6.21 Monitor > Statistic
The following table describes the items in the previous figure.

Table 6.17: Setting (VCOM 1.0)
Item Description
Operation Mode Display the current operation mode of the selected port.
Baud Rate Display the current baud rate of the selected port.
Data Bits Display the current data bits of the selected port.
Stop Bits Display the current stop bits of the selected port.
Parity Display the current parity of the selected port.
RTS/CTS Display the current RTS/CTS status of the selected port.
XON/XOFF Display the current XON/OFF status of the selected port.
DTR/DSR Display the current DTR/DSR status of the selected port.

Table 6.18: Statistic (VCOM 1.0)
Item Description
Tx Count Display the current Tx count of the selected port.
Rx Count Display the current Rx count of the selected port.
Total Tx Count Display the current total Tx count of the selected port.
Total Rx Count Display the current total Rx count of the selected port.
RTS Display the current RTS status of the selected port.
CTS Display the current CTS status of the selected port.
DTR Display the current DTR status of the selected port.
DSR Display the current DSR status of the selected port.
DCD Display the current DCD status of the selected port.
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6.8.3 Connected IP (VCOM 1.0)
The Monitor Connected IP page allows for easy viewing of all connected device’s IP
address.
To access this page, click Monitor > Connected IP.
 

Figure 6.22 Monitor > Connected IP

The following table describes the items in the previous figure.

6.8.4 Status (VCOM 2.0)
VCOM Protocol Version 2.0 is chosen, information on the serial port function is pre-
sented in the Status section.

Figure 6.23 Monitor > Status

The following table describes the items in the previous figure.

Table 6.19: Connected IP (VCOM 1.0)
Item Description
Connected IP Displays the IP designation for the device.
IP Address Displays the current connected IP address of the selected port.
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6.8.5 VCOM Statistics (VCOM 2.0)
The maximum response time measurement is shown in the VCOM Statistics section
of the page. You can check the actual maximum response time of the nodes, and
adjust the timeout parameters accordingly.

Figure 6.24 Monitor > VCOM Statistics

6.8.6 VCOM Clients (VCOM 2.0)
Display diagnostic information for VCOM clients, including addresses and connection
start times.

Figure 6.25 Monitor > VCOM Clients 

6.8.7 VCOM History (VCOM 2.0)
Display diagnostic information for connected VCOM clients, including addresses and
connection start and end times. 

Figure 6.26 Monitor > VCOM History

Table 6.20: Status (VCOM 2.0)
Item Description
TX Display the TX count of the selected port. 
RX Display the RX count of the selected port. 
Modem Display any active modem signals (RTS, CTS, DTR, DSR, DCD) 
Baud Rate Display the current baud rate of the selected port. 
Data Bits Display the current data bits of the selected port. 
Stop Bits Display the current stop bits of the selected port. 
Parity Display the current parity of the selected port. 
RTS/CTS Display the current RTS/CTS status of the selected port. 
XON/XOFF Display the current XON/OFF status of the selected port. 
DTR/DSR Display the current DTR/DSR status of the selected port.
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6.8.8 Just-In-Time Diagnostics (VCOM 2.0)
The Just-In-Time (JIT) Diagnostics features of the device server assist in trouble-
shooting communication issues.
The JIT Event Analyzer allows for the dynamic insertion of multiple event trackers
into a communication session at runtime for in-depth analysis, while JIT System Sta-
tistics continuously records data from each end device and TCP session, providing
valuable insights for performance tuning and future audits. Additionally, the JIT Diag-
nostics feature helps resolve communication issues between the EKI network and
downstream serial devices by enabling remote analysis and checking device status
before disconnection.
JIT diagnostics can be enabled on Service > VCOM page, selecting VCOM 2.0, and
saving your changes.
On the Syslogd > Syslogd Setting page, enable Syslogd and save your changes.
Reboot the device (Tools > Reboot) to apply the changes. JIT logs will then be dis-
played on the Syslogd > Syslogd Message page.
 

Figure 6.27 Monitor > Just-In-Time Diagnostics

6.9 Auto Warning (Alarm)
You can set the e-mail server and SNMP Trap server in the setting page, and set the
event type in the Event page.

6.9.1 Setting
The Alarm Setting menu includes three alarm setting menus for event notification:
Mail Sever, SNMP Trap Server, and the SNMP Agent Setting.
At the top of the list is the Mail Server setting which allows you to specify the mail
server to be used by the serial device server in order to deliver notifications to
selected Email accounts.
The SNMP Trap Server settings allows you to specify the management station of a
significant event by way of an unsolicited SNMP message.
The Simple Network Management Protocol (SNMP) is used by the serial device
server to collect detailed information about the serial device server. To access this
page, click Alarm > Setting.
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Figure 6.28 Alarm > Setting

The following table describes the items in the previous figure.

Table 6.21: Setting
Item Description
Mail Server
Mail Server Enter the SMTP mail server.
From Email Address Enter the email address.
Email Address 1 Enter the email address 1 to receive alarm emails.
Email Address 2 Enter the email address 2 to receive alarm emails.
Email Address 3 Enter the email address 3 to receive alarm emails.
Email Address 4 Enter the email address 4 to receive alarm emails.
SNMP Trap Server
Trap Server Enter the SNMP Trap server address.
Trap Server Port Enter the SNMP Trap server port.

Trap Version Click the radio button to select the SNMP version credentials: v1 or 
v2c or v3.

Trap Community Enter the community string to be passed for the specified event.
SNMP Agent Setting
Read Community Enter the read-only, public, community string.
Write Community Enter the write-only, private, community string.
SNMPv3 User Name Enter the user’s name for network search of SNMPv3.
SNMPv3 Password Enter the password for network search of SNMPv3.
SNMPv3 Authentication 
Type

Select authentication based on the MD5 or SHA.
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6.9.2 Event
The Alarm Event page allows the selection of triggers for system, DCD and DSR
events for the alarm function.
To access this page, click Alarm > Event.
 

Figure 6.29 Alarm > Event 

The following table describes the items in the previous figure.

SNMPv3 Privacy Type Select data encryption type based on DES or AES.
Contact Enter the individual designated the contact point for this event.
Location Enter the designated location/department of the setting.
Save Click Save to save the values and update the screen.

Table 6.21: Setting
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6.10 Syslogd
The EKI-1526 Series device server provides the functionality to allow network
devices to send event messages to a logging server, also known as a Syslog server,
by way of the Syslogd function. The Syslog protocol is supported by a wide range of
devices and can be used to log different types of events.

6.10.1 Syslogd Setting
Users can enable the syslogd function to record historical events or messages locally
or on a remote syslog server.
To access this page, click Syslogd > Syslogd Setting.
 

Figure 6.30 Syslogd > Syslogd Setting 

Table 6.22: Event
Item Description
System Event

Cold Start Click the option to select a warning type when the device server’s 
power is cut off and reconnected.

Warm Start Click the option to select a warning type when the device server is 
reboot.

Authentication Failure Click the option to select a warning type when an incorrect pass-
word is entered.

IP address Changed Click the option to select a warning type when the IP address is 
changed.

Password Changed Click the option to select a warning type when the password is 
changed.

Ethernet1 Link Down Click the option to select a warning type when the Ethernet 1 port is 
disconnected.

Ethernet2 Link Down Click the option to select a warning type when the Ethernet 2 port is 
disconnected.

DCD Changed

Port
Click the option to select a warning type of the selected port when 
a change in the DCD (Data Carrier Detect) signal indicates that the 
modem connection status has changed.

DSR Changed

Port
Click the option to select a warning type of the selected port when 
a change in the DSR (Data Set Ready) signal indicates that the 
data communication equipment is powered off.

Save Click Save to save the values and update the screen.
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Figure 6.31 Syslogd > Syslogd Setting 

The following table describes the items in the previous figure.

6.10.2 Syslogd Message
After enabling the syslogd function, users can check the history in the syslogd mes-
sage page.
To access this page, click Syslogd > Syslogd Message.
 

Figure 6.32 Syslogd > Syslogd Message

The message types selected on the Syslogd Setting page will be displayed. If Just-
In-Time (JIT) Diagnostics are enabled, those messages will also appear here. 

Table 6.23: Syslogd Setting
Item Description
Syslogd Click Enabled or Disabled to set the logging service status.

Syslogd Remote
Enable to send syslogd messages to a remote syslog server.
Note that syslogd messages will not display in the local window 
when the remote feature is active.

Syslogd Remote IP 
Address Enter Syslogd Remote IP address.

VCOM Display syslog messages relay to VCOM 1.0 mode
USDG Display syslog messages relay to USDG 1.0 mode
Save Click Save to save the values and update the screen.
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The Record function will create a temporary file in the browser to record the logs in
the Syslogd Message window. Recording will continue until the button is clicked
again, then the file will be downloaded to your PC as a text file.

6.10.3 VCOM Status 
If the VCOM TLS handshake fails and the port cannot be identified, the error mes-
sage will appear here.
 

Figure 6.33 Syslogd > VCOM Status

6.11 Tools
The EKI-1526 Series device server provides tools for access to ping and reset func-
tions.

6.11.1 Ping
The Ping page can help users diagnose Ethernet problems. Users can use the ping
page to ask the device to ping a specific target to check the Ethernet network status.
The Ping page allows you to configure the test log page. To access this page, click
Tools > Ping.
 

Figure 6.34 Tools > Ping

The following table describes the items in the previous figure.

Table 6.24: Ping
Item Description

IP

Enter the IP address or host name of the station to ping. The initial value 
is blank. The IP Address or host name you enter is not retained across a 
power cycle. Host names are composed of series of labels concatenated 
with periods. Each label must be between 1 and 63 characters long, 
maximum of 64 characters.
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6.11.2 Certs Generator
All security-related functions require the corresponding certificate files to be imported
into the device in order to properly enable HTTPS, VCOM, and USDG features.

Certificates can be generated in multiple ways:
Using EKI Utility (Tools > Create CA), on Windows OS, or using VCOM Driver on
Linux OS or using the WebGUI Certs Generator page. Certs Generator page pro-
vides the ability to create certificates and deploy them with one click to the selected
security functions.

To access this page, click Tools > Certs Generator.

1. Under Generate RootCA Cert and Download: 
Fill in the required information.
Press the Generate and Download button.
A confirmation dialog will appear showing Download Success to verify that the file
x_rootca.tar has been successfully downloaded.
 

2. Generate Target Cert and Download
Fill in the required information.
Press the Generate and Download button.

Size Enter the size of ping packet. The default value is 56. The value ranges 
from 8 to 5120. The size entered is not retained across a power cycle.

Count
Enter the number of echo requests to send. The default value is 4. The 
value ranges from 1 to 5. The count entered is not retained across a 
power cycle.

Interface Select the Ethernet port to use for the ping.
Run ping Display the ping reply format.

Table 6.24: Ping
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A confirmation dialog will appear showing Download Success to verify that the file
x_target .tar has been successfully downloaded.
 

Click the Deploy button to quickly deploy the certificate to the corresponding func-
tion.

6.11.3 Reboot
The configuration will take effect after clicking Save button. All configurations are
saved to flash memory after a system reboot. Press the Reboot button and the sys-
tem will give a reset response. It will take a few seconds to reconnect with the new
values.
To access this page, click Tools > Reboot.

Figure 6.35 Tools > Reboot

Click Yes to reboot the serial device server. Any configuration changes you have
made since the last time you saved will be lost.
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6.12 Management
The EKI-1526 Series device server allows for easy installation and maintenance and
reliable maintenance access from anywhere. With the reliable management tools
available, you can streamline staffing and troubleshooting requirements to a central-
ized system.

6.12.1 Log File
If users enable the system event or serial event to log in file, users can download the
log file from here.
To access this page, click Management > Log File.

Figure 6.36 Management > Log File 

The following table describes the items in the previous figure.

6.12.2 Change Password
The Change Password function allows you to easily update your current password
from a single menu.
To access this page, click Management > Change Password.

Figure 6.37 Management > Change Password

The following table describes the items in the previous figure.

Table 6.25: Log File
Item Description

System Log File
Click the drop-down menu to select a specific action for the system 
log file. Available options: Download System Log, Remove System 
Log, Download and Remove System Log.

Export Click Export to download the log file.
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If you have set a password, when you access the web configuration you need to key
in the password. It is not necessary to enter the user name in the dialog. If you want
to disable the password protection, change the password to the default option None
(leave the new password column blank). Be sure to press the Save button and reboot
the Modbus gateway to make the change effective.

6.12.3 Secure access IP
To access this page, click Management > Secure access IP.
 

Figure 6.38 Management > Secure access IP 

The following table describes the items in the previous figure.

6.12.4 Export Device Settings
Export the server configuration settings to a .conf file.
To access this page, click Management > Export.
Click Export to export the serial device server settings.

6.12.5 Import Device Settings
Import the server configuration settings to a .conf file. To access this page, click Man-
agement > Import.

Table 6.26: Change Password
Item Description
Utility Password
New Password Enter the character set for the define password type.
New Password Again Retype the password entry to confirm the profile password.
Save Click Save to save the values and update the screen.
Web Enhanced Password
New Password Enter the character set for the define password type.
New Password Again Retype the password entry to confirm the profile password.
Save Click Save to save the values and update the screen.

Note! If a password is set, a 20-minute session timer will start each time you 
log in to the web interface. To reset the timer before it expires, click the 
Session Timeout display at the top of the Web UI. When the session 
timer expires, you will be automatically logged out of the web interface.

Table 6.27: Secure access IP
Item Description
Access IP Number Enter a value to define access IP number 
Save Click Save to save the values and update the screen.
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Figure 6.39 Management > Import

The following table describes the items in the previous figure.

6.12.6 Firmware Upgrade
RAUC enables a secure and reliable firmware upgrade mechanism.
1. Set the local time correctly
To access this page, click System.
 

Ensure the device system time is accurate to avoid certificate validation errors during
the upgrade process.

2. Start the upgrade
Go to Management > Firmware Upgrade and Upload the firmware file.
Select the firmware bundle file (e.g., EKI-1526-D_D1.36_r7105.raucb).
Click Upload to transfer the file to the device.
Click the Flash button to initiate the upgrade process.
 

After the upgrade is completed successfully, the device will automatically reboot with
the new firmware.

Table 6.28: Import Device Settings
Item Description
Choose File Click Choose File to select the configuration file.
Submit Click Submit to back up the settings.
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Figure 6.40 Management > Firmware Upgrade
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Chapter 7
7 Telnet and SSH
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7.1 Overview
EKI-152x device server not only allows users to log in and configure the device via
EKI Utility or Web GUI, but it also provides Telnet or SSH access to the EKI-152x,
allowing users to view the device server through commands.

7.2 Create a Telent Connection
Enable the Telnet function in the EKI-152x Web GUI. 
 

Figure 7.1 Enable Telent or SSH Function

Then, search for the "Command Prompt" application in your computer's search bar
and open it.

Note! For security reasons, we recommend using SSH instead of Telnet. SSH 
(Secure Shell) is an encrypted network protocol that establishes a 
secure tunnel for network transmission, providing encrypted remote 
connections.
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Figure 7.2 Open the Command Prompt

In the Command Prompt, type "telnet" followed by the EKI-152x device's local net-
work IP address, and press Enter. For example, if the EKI-152x local network IP is
10.0.0.1, type "telnet 10.0.0.1" and press Enter.
 

Figure 7.3 Telnet Connection

At the command prompt, you can type a “help” followed by the Enter button, or <Tab>
twice, to display the command list. You can toggle between the different command
menu options. 
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7.3 Serial Console
7.3.1 Connecting the cable

You can connect to the EKI-1526 serial device server’s console port with a RS-232
DB9 M-type communication cable, with the other end connecting to the host’s serial
port. Make sure the connection is OK and then download and run the PuTTY on your
host.

7.3.2 COM Port Settings
To connect the EKI-1526 device server for console configuration, the port setting
should match the EKI-1526 device sever default settings.
 

Figure 7.4 COM Port Settings

Console configuration default Settings:
 Serial line: “ * ” of “ttyADV*”
 Speed: 38400
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7.4 Command List

7.4.1 System
Usage: system

Show current device status and informations.
Usage: system name [Maximum length 31 bytes] 

Set current device name.
Usage: system desc [Maximum length 127 bytes]

Set current device description.

7.4.2 Port
Usage: port [nn|all]

Show port status and informations.
Usage: port [nn] desc [Maximum length 127 bytes] 

Set serial port description.
Usage: port [nn|all] type [232|422|485] flow [] 

Set serial port type and flow control.
– flow 0:None.
– flow 1:XOn/XOff. – flow 2:RTS/CTS.
– flow 3:DTR/DSR.

Usage: port [nn|all] baud [50-921600] parity [] data [5-8] stop [1|1.5|2]
Set serial baud rate, parity and numbers of data bits, numbers of stop bits.
Acceptable baud: 50 75 110 150 300 600 1200 1800 2400 4800 7200 9600
14400 19200 38400 57600 115200 230400 460800 921600

– parity n: None Parity.
– parity e: Even Parity.

Table 7.1: Command List
Command Function Description
system Show or configure the system information
port Show or configure the serial ports information
portadv Show or configure the serial ports advanced settings
mvcom Show or configure the serial ports in Virtual COM mode
mctr Show or configure the serial ports in Control mode (USDG)
mdata Show or configure the serial ports in Data mode (USDG)
net Show or configure the Ethernet ports settings
password Set or change the password
alarm Show or configure the auto warning functions including mail alarm 

and SNMP alarm
monitor Monitor the serial ports status
mrfc2217 Show all port modes and mode information.
apply Write settings to the flash memory and reboot the system immedi-

ately
exit Terminate the shell session
help Display command list help information
reboot Write settings and reboot the system immediately.



EKI-1526 User Manual 94

– parity o: Odd Parity.
– parity m: Mark Parity.
– parity s: Space Parity.

Usage: port [nn|all] mode [vcom|ctrl|data]
Set serial port as virtual COM port or control mode or data mode.

7.4.3 Portadv
$ help portadv

Show port advanced setting.
Usage: portadv [nn|all] delayT [] 

Set delay time(ms).
Usage: portadv [nn|all] ignorepurge [TRUE|FALSE] dischato [TRUE|FALSE] dismulti-
con [TRUE|FALSE]

Enable or disable the feature of ignore purge.
Disable character timeout detection, and disable multiple connection.

Usage: portadv [nn|all] databuf [] 
Set databuffer threshold.

Usage: portadv [nn|all] timeout [] rtl [] ttl [] fcl [] fch []
Set port timeout, and set portrtl, portttl, portfcl, portfch.

Usage: portadv [nn|all] fifosize [size|null]
Set port Writed size of FIFO, null for disable.

Usage: portadv [nn|all] rts [] Set port RTS status.
– value 0: None Setting.
– value 1: Setting power on.
– value 2: Setting accept on.
– value 4: Setting transmission on.

Usage: portadv [nn|all] dtr [] Set port DTR status.
– value 0: None Setting.
– value 1: Setting power on.
– value 2: Setting accept on.
– value 4: Setting transmission on.

7.4.4 Mvcom
Usage: mvcom

Show all port mode and mode informations.
Usage: mvcom [nn|all]

Set port [nn|all] as virtual COM port mode.
Usage: mvcom [nn|all] idleto [] 

Set host idle timeout(s).
Usage: mvcom [nn|all] respto [] framebk []

Set response timeout(ms) and frame break(ms).
Usage: mvcom [nn|all] bysize []
Usage: mvcom [nn|all] bytime []
Usage: mvcom [nn|all] bychar [NULL|]

Set datapackage as size(bytes) or time(ms) and character(HEX) .
– value 0: None Setting.
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7.4.5 Mctrl
Usage: mctrl

Show port mode and mode informations.
Usage: mctrl [nn|all]

Set port [nn|all] as control mode.
Usage: mctrl [nn|all] idleto [] tcpp [] atp [] guardt [] hangchr []

Set data idle timeout(s) data listen port command listen port   guard time(ms)
hangup character.

7.4.6 Mdata
Usage: mdata

Show port mode and mode informations.
Usage: mdata [nn|all]

Set port [nn|all] as data mode.
Usage: mdata [nn|all] protocol [TCP|UDP]

Set transmit protocol as TCP or UDP.
Usage: mdata [nn|all] idleto [] lsport [] atport []

Set data idle timeout(s) listen port and AT command port.
Usage: mdata [nn|all] respto [] framebk []

Set response timeout(ms) and frame break(ms).
Usage: mdata [nn|all] bysize [] bytime [] bychar [NULL|] bychartimeout [ON|OFF]

Set datapackage as size(bytes) or time(ms) or character(HEX) and character-
timeout.

– value 0: None Setting.
Usage: mdata [nn|all] autopeerip [ON|OFF]
Set auto connect to peer ip as on or off.
Usage: mdata [nn|all] peernum [1-16] peer [d.d.d.d:d] ...
Set peer IP address and port for receive data.

7.4.7 Net
Usage: net [1|2]

Show device network status and informations.
Usage: net [1|2] mode [static|dhcp|bootp|all] 

Set network operating mode.
Usage: net [1|2] ip [d.d.d.d] netmask [d.d.d.d] gw [d.d.d.d] 

Set IP address and subnet mask and gateway.
Usage: net [1|2] dns [auto|specific] 

Enable/Disable DNS.
Usage: net [1|2] dns1 [d.d.d.d] 

Set network DNS1.
Usage: net [1|2] dns2 [d.d.d.d] 

Set network DNS2.
Usage: net [1|2] to [d]

Set network timeout.
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7.4.8 Password
Usage: password

Display two different Usage.
Usage: password new [1-31 characters] 

Set new password.
Usage: password old [**...] new [1-31 characters]

Confirm the old password and set new password.

7.4.9 Alarm
Usage: alarm

Show current alarm informations.
Usage: alarm mail server [null|address] from [null|address] to1 [null|address] to2
[null|address] to3 [null|address] to4 [null|address] 

Set current mail server configuration.
Usage: alarm trap server [null|address] ver [1|2] community [null|name] 

Set current trap server configuration.
Usage: alarm agent rcommunity [null|name] wcommunity [null|name] contact
ull|name] location [null|name]

Set current snmp agent configuration.
Usage: alarm event mail [cstart] [wstart] [auth] [ip] [passwd] [eth1] [eth2] 

Set current mail event configuration.
Usage: alarm event trap [cstart] [wstart] [auth] [eth1] [eth2] 

Set current trap event configuration.
Usage: alarm port [1|2|..] dcd [none|mail|trap|all] dsr [none|mail|trap|all] 

Set current port alarm configuration.

7.4.10 Monitor
Usage: monitor port [1|2|..] setting Monitor COM port setting
Usage: monitor port [1|2|..] statistic

Monitor COM port statistic data
Usage: monitor port [1|2|..] ip Monitor connected IP

7.4.11 Time
Usage: time

Show current time informations.
Usage: time [YYYYMMDDhhmmss]

Set current time configuration.
Usage: time ntp [timeserver]

Set current time server configuration.

7.4.12 Service
Usage: service telnet [enable|disable] Enable/Disable telnet function
Usage: service snmp [enable|disable] Enable/Disable SNMP function

7.4.13 Mrfc2217
Usage: mrfc2217
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Show all port mode and mode informations.
Usage: mrfc2217 [nn|all]

Set port [nn|all] as RFC2217 mode.
Usage: mrfc2217 [nn|all] idleto [] lsport []

Set host idle timeout(s) and listen port.

7.4.14 Apply
Usage: apply

Save the settings to flash and reboot right now.

7.4.15  Exit
Usage: exit

Terminate shell session

7.4.16 Help
Usage: help [cmd]

Display help information of command cmd

7.4.17 Reboot
Usage: reboot

Write settings and reboot the system immediately.
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Chapter 8
8 TCP and UDP Port
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8.1 List of Known TCP and UDP Port Numbers

Table 8.1: List of Known TCP and UDP Port Numbers
Port Protocol Service
5048 (TCP/UDP) Configuration Utility
5058 (TCP/UDP) Configuration Utility
5202 (TDP) VCOM/RVCOM
9999 (TDP) Firmware Download
22 (TDP) SSH
23 (TDP) Telnet
25 (TDP) SMTP (Mail Client)
53 (TCP/UDP) DNS
67 (UDP) BOOTP Server/DHCP
68 (UDP) BOOTP Client/DHCP
80 (TDP) Web Interface/HTTP
123 (TDP) NTP
161 (TDP) SNMP
162 (TCP/UDP) SNMP Trap
443 (TDP) HTTPS
502 (TDP) Modbus/TCP (Default)
514 (TDP) Syslog
546 (TCP/UDP) DHCPv6 Client
547 (TCP/UDP) DHCPv6 Server
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